OUI Crash In Module Libj9jit23.so With IBM JDK/JRE 1.5 SR4 On AIX When Running On The New POWER7 Based Hardware [ID 1065579.1]

Applies to:

Oracle Universal Installer - Version to [Release 11.1]
IBM AIX on POWER Systems (64-bit)


IBM has reported that the Oracle Universal Installer (OUI) will crash with IBM JDK/JRE 1.5 SR4 on AIX when running on the new POWER7 based hardware.


This impacts the install of Oracle Database 11gR1 Versions and on the POWER7 Systems.


OUI (aka ./runInstaller) will crash with errors similar to
% ./runInstaller

Starting Oracle Universal Installer...
Checking Temp space: must be greater than 190 MB. Actual 1113 MB Passed
Checking swap space: must be greater than 150 MB. Actual 16384 MB Passed
Checking monitor: must be configured to display at least 256 colors. Actual 16777216 Passed
Preparing to launch Oracle Universal Installer from /tmp/OraInstall2010-04-26_05-37-48PM. Please wait ...$ Oracle Universal Installer, Version Production
Copyright (C) 1999, 2007, Oracle. All rights reserved.
Unhandled exception
Type=Segmentation error vmState=0x00000000
J9Generic_Signal_Number=00000004 Signal_Number=0000000b Error_Value=00000000 Signal_Code=00000033
Handler1=09001000A07DEC78 Handler2=09001000A07D6538
Target=2_30_20070131_11312_BHdSMr (AIX 6.1)
CPU=ppc64 (4 logical CPUs) (0x300000000 RAM)




  1. Download and unzip Patch 9216848
  2. Install the patch carefully following the README
Also, as an available work-around it has also been shown that you may install an updated JDK 1.5 [SR 8 or later] that works on the power 7 processor,
in this case the workaround will be to launch OUI this way : ./runInstaller -jreloc <path of O.S jre>



26-May-2010 Added error to Symptoms section.
18-Mar-2010 Updated Workaround and Patch section with resolution for issue
23-Jul-2010 Proccessed Pending comment:  Install an updated JDK 1.5 [SR 8 or latter] that works on the power 7 processor.
Run 'opatch -jdk <PATH to new jdk>

Niciun comentariu:

Trimiteți un comentariu